$re = '/((?:.*?one.*?){1}.*?)one/m';
$str = 'one two three one one asdfasdf one asdfasdf sdf one
';
$subst = "\1\(one\)";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;