import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\^([\\s\\S]*?)\\]";
final String string = "Then he said FUCKIT[^This is where I need to insert some MD] you're all going to hell\n\n"
+ "Then he said FUCKIT[^it \n"
+ "should\n\n"
+ "]s\n"
+ "be multiline] you're all going to hell\n\n"
+ "Then he said FUCKIT[^it \n"
+ "should \n"
+ "#contain MD\n"
+ "be multiline] you're all going to hell\n\n\n\n"
+ "(?=\\])";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}