// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\[\^([\s\S]*?)\]").unwrap();
let string = "Then he said FUCKIT[^This is where I need to insert some MD] you're all going to hell
Then he said FUCKIT[^it
should
]s
be multiline] you're all going to hell
Then he said FUCKIT[^it
should
#contain MD
be multiline] you're all going to hell
(?=\\])";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}