use strict;
my $str = 'Then he said FUCKIT[^This is where I need to insert some MD] you\'re all going to hell
Then he said FUCKIT[^it
should
]s
be multiline] you\'re all going to hell
Then he said FUCKIT[^it
should
#contain MD
be multiline] you\'re all going to hell
(?=\\])';
my $regex = qr/\[\^([\s\S]*?)\]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}