re = /\[\^([\s\S]*?)\]/
str = 'Then he said FUCKIT[^This is where I need to insert some MD] you\'re all going to hell
Then he said FUCKIT[^it
should
]s
be multiline] you\'re all going to hell
Then he said FUCKIT[^it
should
#contain MD
be multiline] you\'re all going to hell
(?=\\])'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end