$re = '/\[\^([\s\S]*?)\]/';
$str = 'Then he said FUCKIT[^This is where I need to insert some MD] you\'re all going to hell
Then he said FUCKIT[^it
should
]s
be multiline] you\'re all going to hell
Then he said FUCKIT[^it
should
#contain MD
be multiline] you\'re all going to hell
(?=\\])';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);