# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/([^\s-])-\n/$1/;t' <<< "A hyphen-
ated line.
Mary Rose sat on a pin -
Mary rose.
Mary Rose sat on a pin --
Mary rose."