import Foundation
let pattern = #"([^\s-])-\n"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
A hyphen-
ated line.
Mary Rose sat on a pin -
Mary rose.
Mary Rose sat on a pin --
Mary rose.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}