using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([^\s-])-\n";
string substitution = @"$1";
string input = @"A hyphen-
ated line.
Mary Rose sat on a pin -
Mary rose.
Mary Rose sat on a pin --
Mary rose.";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}