#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "([^\s-])-\n"
Local $sString = "A hyphen-" & @CRLF & _
"ated line." & @CRLF & _
"" & @CRLF & _
"Mary Rose sat on a pin -" & @CRLF & _
"Mary rose." & @CRLF & _
"" & @CRLF & _
"Mary Rose sat on a pin --" & @CRLF & _
"Mary rose."
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)