const regex = /([^\s-])-\n/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([^\\s-])-\\n', '')
const str = `A hyphen-
ated line.
Mary Rose sat on a pin -
Mary rose.
Mary Rose sat on a pin --
Mary rose.`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);