re = /([^\s-])-\n/
str = 'A hyphen-
ated line.
Mary Rose sat on a pin -
Mary rose.
Mary Rose sat on a pin --
Mary rose.'
subst = '$1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result