// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"([^\s-])-\n").unwrap();
let string = "A hyphen-
ated line.
Mary Rose sat on a pin -
Mary rose.
Mary Rose sat on a pin --
Mary rose.";
let substitution = "$1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}