#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\w{8})(\w{4})(\w{4})(\w{4})(\w{12})"
Local $sString = "392981414524f56f68d9f4a47e7072f2"
Local $sSubst = "$1-$2-$3-$4-$5"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)