using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w{8})(\w{4})(\w{4})(\w{4})(\w{12})";
string substitution = @"$1-$2-$3-$4-$5";
string input = @"392981414524f56f68d9f4a47e7072f2";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}