use strict;
my $str = '392981414524f56f68d9f4a47e7072f2';
my $regex = qr/(\w{8})(\w{4})(\w{4})(\w{4})(\w{12})/mp;
my $subst = '$1-$2-$3-$4-$5';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";