package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\w{8})(\w{4})(\w{4})(\w{4})(\w{12})`)
var str = `392981414524f56f68d9f4a47e7072f2`
var substitution = "$1-$2-$3-$4-$5"
fmt.Println(re.ReplaceAllString(str, substitution))
}