// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\w{8})(\w{4})(\w{4})(\w{4})(\w{12})").unwrap();
let string = "392981414524f56f68d9f4a47e7072f2";
let substitution = "$1-$2-$3-$4-$5";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}