import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w{8})(\\w{4})(\\w{4})(\\w{4})(\\w{12})";
final String string = "392981414524f56f68d9f4a47e7072f2";
final String subst = "$1-$2-$3-$4-$5";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}