$re = '/(\w{8})(\w{4})(\w{4})(\w{4})(\w{12})/m';
$str = '392981414524f56f68d9f4a47e7072f2';
$subst = "$1-$2-$3-$4-$5";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;