# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/{2,}(?:(?!\\/\\/).)*?$//gm;t' <<< "output port_a; // comments remove this port
// output port_a; // comments remove this port
// output port_a;
// output port_a; // comments read/write
// output port_a; // more // comments remove this port
// output port_a; // more // more // more // comments remove this port"