const regex = /\/{2,}(?:(?!\/\/).)*?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/{2,}(?:(?!\\\/\\\/).)*?$', 'gm')
const str = `output port_a; // comments remove this port
// output port_a; // comments remove this port
// output port_a;
// output port_a; // comments read/write
// output port_a; // more // comments remove this port
// output port_a; // more // more // more // comments remove this port`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);