$re = '/\/{2,}(?:(?!\/\/).)*?$/m';
$str = 'output port_a; // comments remove this port
// output port_a; // comments remove this port
// output port_a;
// output port_a; // comments read/write
// output port_a; // more // comments remove this port
// output port_a; // more // more // more // comments remove this port';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;