import re
regex = re.compile(r"\/{2,}(?:(?!\/\/).)*?$", flags=re.MULTILINE)
test_str = ("output port_a; // comments remove this port\n"
"// output port_a; // comments remove this port\n"
"// output port_a; \n"
"// output port_a; // comments read/write \n\n"
"// output port_a; // more // comments remove this port\n\n"
"// output port_a; // more // more // more // comments remove this port")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)