use strict;
my $str = 'àbâbã
abábä';
my $regex = qr/[àâáãä]/mp;
my $subst = 'a';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";