import re
regex = re.compile(r"[àâáãä]", flags=re.MULTILINE)
test_str = ("àbâbã\n"
"abábä")
subst = "a"
result = regex.sub(subst, test_str)
if result:
print(result)