# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(@\S+)\s(.+.com)/<a href="$1"> $2 <\/a>/;t' <<< "@xxx test@xxx.com"