// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(@\S+)\s(.+.com)").unwrap();
let string = "@xxx test@xxx.com";
let substitution = "<a href=\"$1\"> $2 </a>";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}