$re = '/(@\S+)\s(.+.com)/';
$str = '@xxx test@xxx.com';
$subst = "<a href=\"$1\"> $2 </a>";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;