import re
regex = re.compile(r"(@\S+)\s(.+.com)")
test_str = "@xxx test@xxx.com"
subst = "<a href=\"$1\"> $2 </a>"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)