use strict;
my $str = '@xxx test@xxx.com';
my $regex = qr/(@\S+)\s(.+.com)/p;
my $subst = '<a href="$1"> $2 </a>';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";