re = /(@\S+)\s(.+.com)/
str = '@xxx test@xxx.com'
subst = '<a href="$1"> $2 </a>'
result = str.sub(re, subst)
# Print the result of the substitution
puts result