#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(\d*)(h|l|r.)"
Local $sString = "hhlhllhlhhll" & @CRLF & _
"rhllllllrw" & @CRLF & _
"rh6l9l4hrw" & @CRLF & _
"9lrL7h2rL" & @CRLF & _
"999999999999999999999999999lr0" & @CRLF & _
"999rsom"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")