const regex = new RegExp('(\\d*)(h|l|r.)', 'gm')
const str = `hhlhllhlhhll
rhllllllrw
rh6l9l4hrw
9lrL7h2rL
999999999999999999999999999lr0
999rsom`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}