using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d*)(h|l|r.)";
string input = @"hhlhllhlhhll
rhllllllrw
rh6l9l4hrw
9lrL7h2rL
999999999999999999999999999lr0
999rsom";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}