import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d*)(h|l|r.)";
final String string = "hhlhllhlhhll\n"
+ "rhllllllrw\n"
+ "rh6l9l4hrw\n"
+ "9lrL7h2rL\n"
+ "999999999999999999999999999lr0\n"
+ "999rsom";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}