$re = '/(\d*)(h|l|r.)/m';
$str = 'hhlhllhlhhll
rhllllllrw
rh6l9l4hrw
9lrL7h2rL
999999999999999999999999999lr0
999rsom';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);