re = /(\d*)(h|l|r.)/m
str = 'hhlhllhlhhll
rhllllllrw
rh6l9l4hrw
9lrL7h2rL
999999999999999999999999999lr0
999rsom'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end