package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\d*)(h|l|r.)`)
var str = `hhlhllhlhhll
rhllllllrw
rh6l9l4hrw
9lrL7h2rL
999999999999999999999999999lr0
999rsom`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}