using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[([^\|]*)\|([^\]]*)\]";
string substitution = @"$2";
string input = @"'Assets have been removed from this pending application.<br />The following [asset is|asset's are] no longer available because [it|they] are no longer active: {0}";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}