use strict;
my $str = '\'Assets have been removed from this pending application.<br />The following [asset is|asset\'s are] no longer available because [it|they] are no longer active: {0}';
my $regex = qr/\[([^\|]*)\|([^\]]*)\]/p;
my $subst = '$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";