re = /\[([^\|]*)\|([^\]]*)\]/
str = '\'Assets have been removed from this pending application.<br />The following [asset is|asset\'s are] no longer available because [it|they] are no longer active: {0}'
subst = '$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result