import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[([^\\|]*)\\|([^\\]]*)\\]";
final String string = "'Assets have been removed from this pending application.<br />The following [asset is|asset's are] no longer available because [it|they] are no longer active: {0}";
final String subst = "$2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}