package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[([^\|]*)\|([^\]]*)\]`)
var str = `'Assets have been removed from this pending application.<br />The following [asset is|asset's are] no longer available because [it|they] are no longer active: {0}`
var substitution = "$2"
fmt.Println(re.ReplaceAllString(str, substitution))
}