import re
regex = re.compile(r"\[([^\|]*)\|([^\]]*)\]")
test_str = "'Assets have been removed from this pending application.<br />The following [asset is|asset's are] no longer available because [it|they] are no longer active: {0}"
subst = "$2"
result = regex.sub(subst, test_str)
if result:
print(result)