using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=href="")(.*?\.(.*?))\\";
string input = @"some random text <a href=""http://localhost/example/wp-content/uploads/2014/07/Link1.pdf\"">Link1</a><a href=""http://localhost/example/wp-content/uploads/2014/07/Link2.pdf\"">Link2</a>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}