const regex = new RegExp('(?<=href=")(.*?\\.(.*?))\\\\', 'g')
const str = `some random text <a href="http://localhost/example/wp-content/uploads/2014/07/Link1.pdf\\">Link1</a><a href="http://localhost/example/wp-content/uploads/2014/07/Link2.pdf\\">Link2</a>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}