import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=href=\")(.*?\\.(.*?))\\\\";
final String string = "some random text <a href=\"http://localhost/example/wp-content/uploads/2014/07/Link1.pdf\\\">Link1</a><a href=\"http://localhost/example/wp-content/uploads/2014/07/Link2.pdf\\\">Link2</a>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}