re = /(?<=href=")(.*?\.(.*?))\\/
str = 'some random text <a href="http://localhost/example/wp-content/uploads/2014/07/Link1.pdf\\">Link1</a><a href="http://localhost/example/wp-content/uploads/2014/07/Link2.pdf\\">Link2</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end