$re = '/(?<=href=")(.*?\.(.*?))\\\\/';
$str = 'some random text <a href="http://localhost/example/wp-content/uploads/2014/07/Link1.pdf\\">Link1</a><a href="http://localhost/example/wp-content/uploads/2014/07/Link2.pdf\\">Link2</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);